Follow

Focusrite product compatibility with macOS 10.15 (Catalina)

Compatibility information for all current products is listed below. Our testing was conducted using various beta versions of macOS Catalina, the "Golden Master" and ultimately the release version of 10.15. 

Newer updates to Catalina (e.g. 10.15.x) may potentially alter the performance of some products compared to the original 10.15 release, though significant changes in this regard throughout the lifecycle of a version of macOS have historically been rare.

Please check that all other software/hardware you use to make music is also compatible before updating and never update your operating system during the middle of a time-critical project. If you're using additional software that came bundled with your Focusrite interface (e.g. Ableton Live Lite, Pro Tools First) then please check the corresponding manufacturer's website for compatibility information.

Based on past experience we would generally advise waiting for a at least a few months after the release of any new operating system before updating in case there are any initial issues which need to be patched.

If you receive an error message stating 'System Extension Blocked' after installing Focusrite software/drivers then please see this article.

If you are having trouble getting signal into audio software but playback seems fine, please see this article.

 

Scarlett 3rd Gen Range (Solo, 2i2, 4i4, 8i6, 18i8 and 18i20)

scarlett3g-range-2560-802.png

Works with Catalina? YES

 

Scarlett 2nd Gen Solo, 2i2 and 2i4

Scarlett-2i4_Front_elevated.jpg

Works with Catalina? YES

 

Scarlett 2nd Gen 6i6, 18i8 and 18i20

18i20_3quart-left.jpg

Works with Catalina? YES

 

Scarlett 1st Gen Solo, 2i2 and 2i4

1stgenwiw.jpg

Works with Catalina? YES

 

Scarlett 1st Gen 6i6, 18i8 and 18i20

1stGen18i201.png

Works with Catalina? YES - please install Scarlett Mix Control 1.10 after selecting your product in our Downloads section.

 

Scarlett 1st Gen 8i6 and 18i6

Works with Catalina? YES - please install Scarlett Mix Control 1.10 after selecting your product in our Downloads section.

We are aware of issues that affect users trying to clock their 1st Gen 8i6/18i6 externally via S/PDIF or ADAT. Users will experience issues when changing clock source and sample rate to invalid clock configurations, for example changing to a clock source that isn’t present, or changing sample rate to one that doesn’t match the current clock source. This behaviour will not be fixed in future as these products are discontinued and are no longer under development support.

 

Clarett USB Range (2Pre USB, 4Pre USB and 8Pre USB)

Screenshot_2018-12-12_at_15.00.58.png

Works with Catalina? YES

 

Clarett Thunderbolt Range (2Pre, 4Pre, 8Pre and 8PreX)

8Pre X

Works with Catalina? YES - note that you may need to right-click on the Mac Thunderbolt Driver installer to run it. If you see an error message that states that the installer "can't be opened because Apple cannot check it for malicious software" then please follow the instructions in this article

 

Red Plugin Suite

RedPlugin.png

Works with Catalina? YES

 

Saffire FireWire Range (Pro 14, Pro 24, Pro 24 DSP, Pro 26, Pro 40, Liquid Saffire 56)

Screen_Shot_2019-09-27_at_13.13.08.png

Works with Catalina? YES - all Saffire FireWire interfaces are compatible with macOS 10.15 Catalina using Saffire Mix Control 3.9 (available in our Downloads area).

Please note that the Saffire FireWire Range is no longer under development support, please see our full statement regarding the end of development support for the Saffire Range here.

 

iTrack Solo

iTrackSolo.jpg

Works with Catalina? YES

 

Saffire 6 USB

Saffire6.jpg

There are two variants of the Saffire 6 USB - one is a USB 1.1 device and the other is USB 2.0. To check which variant you have you can reference the serial number on the underside of the unit: if the serial begins "SU" then you have the USB 1.1 variant, it it begins "S2" then you have the USB 2.0 variant.

Works with Catalina (USB 1.1)? NO - therefore we recommend that Saffire 6 USB 1.1 users do not upgrade their macOS to Catalina.

Our full statement regarding the end of development support for Saffire 6 USB 1.1 can be found here.

Works with Catalina (USB 2.0)? YES

 

Forte

Forte.jpg

Works with Catalina? NO - Forte is not supported on macOS 10.15 Catalina, therefore we recommend that Forte users do not upgrade their macOS to Catalina. Forte Control may work if you're updating from an older version of macOS but this is untested and unsupported. The Forte Control installer will fail if it's run on macOS Catalina.

Our full statement regarding the end of development support for Forte can be found here.

 

Scarlett Plugin Suite

scarlettplugin.jpeg

Works with Catalina? YES

While the Scarlett Plugin Suite may still work we have ended development support and as such these plugins are no longer tested so we cannot guarantee compatibility. Our full statement regarding the end of development support for Scarlett Plugin Suite can be found here.

 

Midnight Plugin Suite 

Midnight-Plugin-Suite.jpg

Works with Catalina? YES

While the Midnight Plugin Suite may still work we have ended development support and as such these plugins are no longer tested so we cannot guarantee compatibility. Our full statement regarding the end of development support for Midnight Plugin Suite can be found here.

 

For compatibility information on Focusrite Pro products (e.g. RedNet and Red) please see this article.

If your product is not listed then it has not been tested with macOS Catalina and therefore may not work correctly.

Was this article helpful?
11 out of 13 found this helpful
Have more questions? Submit a request

Comments

Didn't find what you were looking for?

Search again using our search tool.