Media Icons Facebook Twitter Google+ RSS Focusrite TV Focusrite Soundcloud

Follow

I'm getting clicks and pops on my computer that has an AMD processor

This applies to the 1st Generation Scarlett 2i2, 2i4, Solo and iTrack Solo (not 2nd Generation)

If you're using a bus powered USB interface with the latest release driver (v3.1.10), or another Scarlett interface with either a beta version of Scarlett MixControl (v1.9b4) or the Focusrite USB 2.0 driver (v3.1.10b) then you may run into audio performance issues when using a USB 2.0 port on a PC with an AMD processor. 

To overcome this you should connect your Scarlett interface to a USB 3.0 port. On your computer these are usually blue ports or have "SS" or "3.0" printed next to them.

If your computer does not have a USB 3.0 port to connect to, please follow these steps:

  • Run the uninstaller for the "Scarlett USB 2.0 Audio & MIDI Driver" from the Scarlett folder in your Start Menu/Panel.
  • From your computer's Device Manager, find the Scarlett interface under "Sound, video and game controllers", then right-click and select uninstall.
  • When asked if you want to delete the driver, tick the box and proceed. 
  • Once the unistall is complete, disconnect your Scarlett interface.
  • Download and install this version of the driver.
  • Restart your computer.
  • Connect your Scarlett interface.

We have addressed this in a driver release that will be available soon on the relevant Scarlett's downloads page, once comprehensive testing is complete. In the meantime, if you're still experiencing problems after following the steps here feel free to get in touch with our support team via the contact us link on the left menu. 

Was this article helpful?
2 out of 4 found this helpful
Have more questions? Submit a request

Comments

Didn't find what you were looking for?

Search again using our search tool.